lunedì 7 novembre 2011

Installazione Hotspot WIFI senza cablaggio strutturato Ethernet

In edifici storici come hotel nelle città d'arte o in antichi borghi o ancora in agriturismi realizzati all'interno di strutture in pietra, si rende impossibile la realizzazione dell'impianto attraverso il semplice cablaggio di comuni access point. La tecnologia WDS dei router Mikrotik pone soluzione a queste problematiche, consentendo di realizzare una rete di Access Point completamente senza fili che autoripete il segnale degli AP vicini senza utilizzare una seconda radio. La realizzazione è infatti conveniente anche dal punto di vista economico giacchè un mini router Mikrotik con radio WIFI si aggira intorno ai 50 €. Una scelta oculata nel tipo di antenna da adottare in ogni singolo punto, a seconda della morfologia del sito da coprire, servirà ad ottimizzare il numero di apparati da acquistare. Uno dei router farà da frontend con l'accesso internet o la LAN del cliente. Questi router professionali non sono solo dotati di un efficacie Firewall ma possono rispondere ad un'infinità di esigenze pratiche come:

- Separare il traffico degli hotspot da quello della LAN del cliente
- Bilanciare l'utilizzo di diverse connessioni internet
- Collegare in VPN più sedi del cliente
- Limitare la banda utilizzata dagli utenti WIFI
- Limitare l'accesso ad alcuni siti

Inoltre questi router integrano completamente in un apposito Mini Web Server le seguenti funzioni tipiche degli Hotspot:

- Identificazione del cliente
- Quantificazione del traffico
- Fatturazione del traffico
- Gestione pagamenti a mezzo PayPal
- Passepartout di alcuni dispositivi
- Rivendita del traffico con tariffe differenti



domenica 6 novembre 2011

100 risultati su una pagina nelle ricerche google

Questo l'obiettivo di gInfinity, plugin del browser chrome
http://www.addictivetips.com/internet-tips/ginfinity-get-100-results-on-first-page-of-google-search-chrome/

giovedì 3 novembre 2011

Occhio ai file WORD, nuovo pericolo

In questo articolo non si parla del solito virus, con le solite modalità di diffusione...
L'articolo non scende molto in dettaglio sulle modalità di infezione, in ogni caso, finchè non se ne sa di più vi sconsiglio di usare file word per condividere dati ... casomai stampate in pdf, oppure usate altri formati ... (RTF, Open document...). Soprattutto vi sconsiglio di aprire quelli che ricevete. Chiedete sempre una forma di invio alternativa. Come al solito avere un'antivirus in se si dimostra essere una falsa sicurezza. I virus escono sempre prima degli antivirus e con l'informatica bisogna sempre usare cautela...

Proprio oggi in ufficio è arrivato un documento che ci aspettavamo e che dovevamo assolutamente aprire.. Ho fatto scaricare OpenOffice alle segretarie e lo abbiamo aperto con quello... Per ora puo' essere una buona soluzione di ripiego.
 Per i file che invece NON VI ASPETTATE, anche da fonti conosciute ... chiedete sempre se l'invio è stato intenzionale prima di aprirli (prima ed unica regola veramente efficace della sicurezza informatica)

Soluzione Gateway d'emergenza

 Negli ultimi giorni la rete internet era piuttosto lenta e a volte si interrompeva del tutto, tipico segnale di un peggioramento della qualità del "doppino". I test di banda in effetti non superavano mai i 4 Mbps ... quando il contratto in realtà sarebbe di 20 Mbps...
Abbiamo chiamato l'ISP facendogli presente la situazione il quale ha attivato la Telecom ... il nostro caro ex monopolista gestore dello stramaledetto ultimo miglio...
Risultato: 3 gg di down senza preavviso con la Telecom che si palleggiava i ticket di banda insufficiente o mancato collegamento!!
Ma ora, come far lavorare l'ufficio?????
Ho pensato che appoggiarsi qualche giorno su qualche WIFI aperta nei dintorni non sarebbe stato un infrazione così grande... Quindi mi sono messo a passeggiare in lungo e in largo per la sede con il telefono Android in modalità SCAN Wifi. Ad una delle estremità dell'ufficio c'era il miglior WIFI aperto con -80 dB di segnale (certo non un segnale forte). Dopo un rapido controllo fatto con il browser era evidente che fosse veramente aperto e privo di proxy di accesso, nonchè collegato a Internet. Ora si trattava di rendere questa risorsa sicura e disponibile per tutta la rete.

Ora passiamo alla realizzazione della soluzione, che in mezz'ora ci ha messo in grado di lavorare. Innanzitutto serviva un router WIFI professionale, era già disponibile l'oggetto perfetto per questa occorrenza: Mikrotik RB411AR + un'antenna omnidirezionale da ben 8 dB che avrebbe portato il livello del segnale a ben -72 dB.

Antenna 8dB con posizionamento di fortuna

I router General Porpuse Mikrotik sono oggetti molto potenti in mano ad utilizzatori professionali, certo non sono oggetti dotati di wizard WEB ...
Il primo passo è stato rendere accedibile questo Bridge router sull'area DMZ del Router Firewall aziendale in modo da rendere protetta l'azienda da questa connessione e piazzarla all'esterno del Firewall.


/ip address

add address=10.1.6.1/30 broadcast=10.1.6.3 comment="" disabled=no interface=ether1 network=10.1.6.0
In questo caso la subnet 10.1.6.0/30 identifica l'area DMZ.
Poi ho allineato la radio con il WIFI aperto e protetto il router con password "solida".

 /interface wireless
set 0 ack-timeout=dynamic adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 antenna-mode=ant-a area="" arp=enabled band=2.4ghz-b/g basic-rates-a/g=6Mbps \
    basic-rates-b=1Mbps burst-time=disabled comment="" compression=no country=italy default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 \
    default-forwarding=yes dfs-mode=none disable-running-check=no disabled=no disconnect-timeout=3s frame-lifetime=0 frequency=2437 frequency-mode=manual-txpower \
    hide-ssid=no hw-retries=4 mac-address=00:0C:42:61:4C:BE max-station-count=2007 mode=station mtu=1500 name=wlan1 noise-floor-threshold=default on-fail-retry-time=\
    100ms periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=000C42614CBE rate-set=default \
    scan-list=default security-profile=default ssid=TISCALI station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=6Mbps,9Mbps supported-rates-b=1Mbps,2Mbps \
    tx-power-mode=default update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=bridge1 wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled \
    wmm-support=disabled


Configurato il DHCP verso l'AP Wifi

/ip dhcp-client
add add-default-route=yes comment="" default-route-distance=0 disabled=no interface=wlan1 use-peer-dns=yes use-peer-ntp=yes


configurato il NAT per mascherare gli indirizzi in uscita dalla radio

/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan1

e il gioco è fatto ;)


...in realtà il router della rete HOST era accessibile secondo i default reperiti su Internet per cui è stato facile (ma non esattamente immediato) guadagnarne l'amministrazione....
Questo è stato utile per poter continuare a fornire supporto aziendale a chi si trovasse in mobilità (VPN, FTP etc...) attraverso l'URL DDNS (DNS dinamico).
Non mi sembra il caso di andare avanti qui con le configurazioni eseguite.. :D

Dopo 3 giorni la nostra connessione è stata ripristinata e ho rimesso tutto a posto ... ;)

Risoluzione malfunzionamento Gateway aziendale

Ieri sono stato raggiunto da una chiamata di un collega mentre ero fuori. L'ufficio per  il quale svolgo la maggior parte delle consulenze non riusciva più a raggiungere Internet. Alle 13 era tutto abbastanza lento e per non sapere ne leggere ne scrivere hanno resettato il modem ADSL PPPoE e il routerOS che fa da firewall gateway trasparent proxy virtualizzato su uno dei nostri server.
Loro non riuscivano ad uscire ma io riuscivo ad accedere dall'esterno sull'IP pubblico...
Stranamente la tabella delle configurazioni NAT era vuota.....
Riconfigurare 2 regole per le NAT sulle interfacce d'uscita è stato naturalmente un gioco da ragazzi...

/ip firewall nat
add action=masquerade chain=srcnat comment=Internet disabled=no \
    out-interface=pppoe-NGI
add action=masquerade chain=srcnat comment="ADSL modem subnet" disabled=no \
    out-interface=DMZ

parte delle informazioni riguardanti gli ultimi test bed accessibili da partner esterni in VPN erano lasciate documentate su Gmail (e quindi facilmente trovabili).
Inoltre c'era un backup abbastanza recente della configurazione dalla quale ho potuto estrarre la traccia per raggiungere la configurazione attuale.
In sostanza ho dovuto aggiungere un NAT per ogni interfaccia VPN in uscita (che utilizziamo per l'accesso di manutenzione presso i siti dei clienti)  e il mapping delle porte per l'FTP e gli altri socket proprietari che ricevono i dati dalle nostre centraline per la misurazione della qualità dell'aria.

e il gioco è fatto ;)

lunedì 31 ottobre 2011

Grande offerta STARTUP

A tutti i nuovi clienti, per le prime 3 ore di consulenza, verrà applicata la speciale tariffa promo di 20 €/ora.

Verificate le altre offerte nella pagina delle TARIFFE

Prezzi I.V.A. esclusa.